Jump to content
  • Sign Up
  • 0
Hedwig7s

How do I only allow 1 protocol version on MCGalaxy

Question

7 answers to this question

Recommended Posts

  • 0

Unless 20-23a implements unique network behavior compared to other versions, this is impossible

Share this post


Link to post
  • 0
12 hours ago, Goodly said:

Unless 20-23a implements unique network behavior compared to other versions, this is impossible

????? MCGalaxy since 1.9.3.5 supports protocol versions 3-7

Share this post


Link to post
  • 0
13 hours ago, icanttellyou said:

????? MCGalaxy since 1.9.3.5 supports protocol versions 3-7

You're right, I forgot that the client actually sends different protocol versions. I was thinking about how classic versions didn't send an AppName, but that's not needed to tell the difference in this case.

So basically it is possible, with a simple plugin. You can copy the KickNoCC plugin and modify it so that instead of checking p.appName, it can check if (p.ProtocolVersion != Server.VERSION_0020) then p.Leave and set p.cancellogin to true

Share this post


Link to post
  • 0
5 hours ago, Goodly said:

You're right, I forgot that the client actually sends different protocol versions. I was thinking about how classic versions didn't send an AppName, but that's not needed to tell the difference in this case.

So basically it is possible, with a simple plugin. You can copy the KickNoCC plugin and modify it so that instead of checking p.appName, it can check if (p.ProtocolVersion != VERSION_0020) then p.Leave and set p.cancellogin to true

so what is each protocol number then?

Share this post


Link to post
  • 0
7 hours ago, Hedwig7s said:

so what is each protocol number then?

Check here for a description of all of them. Also, I forgot that you have to include Server. before the VERSION_0020 in my hypothetical plugin. like

if (p.ProtocolVersion != Server.VERSION_0020)

 

Share this post


Link to post
  • 0
22 hours ago, Goodly said:

Check here for a description of all of them. Also, I forgot that you have to include Server. before the VERSION_0020 in my hypothetical plugin. like

if (p.ProtocolVersion != Server.VERSION_0020)

 

Thanks might update my servers like Generic since it seems less resource intensive

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...